Keyboard Up Arrow Takes Screen Snapshot

In the UBUNTU environment, I recently upgraded from UBUNT Desktop 8.01 to 8.10. After this, my keyboard was not tracking right. The predominent problem was the arrow keys. Pressing them in an email document caused erratic behavior.

The delete key would execute when pressing Print Screen, a Screen Snapshot would occur if pressing the Up Arrow key. And more.

I checked out the System/Preferences/Keyboard Shortcuts, but nothing there was wrong. After some frustration, I finally solved the problem. Having checked in System/Preferences/Keyboard, I found that my Layout was not set correctly. I happen to have a DELL keyboard, and  decided to go through the following steps for a successful resolution:

  1. Access from the menu System/Preferences/Keyboard
  2. Choose “Generic” vendor
  3. Select “Evdev-managed keyboard”
  4. Click OK
  5. Logout and log back in
  6. Confirm it’s working by pressing the Up Arrow key.

This worked for me. I hope this helps for you.

1 thought on “Keyboard Up Arrow Takes Screen Snapshot

Leave a Reply